less than helpful naming conventions

I had to do a little debugging work today in a system that I’m not too familiar with. I came across this line of code:

bool result = processor.Process();

If your code has reached the level of abstraction where the most meaningful name you can give a class is “Processor”, and the most meaningful name you can give the main routine in your class is “Process()”, then you may have gotten a little too abstract.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.